Purolator Rating
Incident Report for Intuitive Shipping
Resolved
Purolator is now returning rates.
Posted Jun 20, 2021 - 23:14 EDT
Monitoring
We are monitoring Purolator's progress in resolving the issue.
Posted Jun 20, 2021 - 19:01 EDT
Investigating
Purolator is currently experiencing rating issues. If you are solely using Purolator rating, we recommend adding a fallback rate or fallback carrier to ensure your customers are able to complete their purchase.
Posted Jun 20, 2021 - 18:50 EDT
This incident affected: Intuitive Shipping Legacy (Rating).