In-app Support Form
Incident Report for Intuitive Shipping
Resolved
This incident has been resolved.
Posted Sep 08, 2021 - 10:26 EDT
Identified
The support form located within the Intuitive Shipping app is currently down. Please email us directly at support@intuitiveshipping.com for any support related requests. We have identified the issue and are currently working to resolve it.
Posted Sep 08, 2021 - 09:37 EDT
This incident affected: Intuitive Shipping Legacy (Admin).