USPS International Carrier Service
Incident Report for Intuitive Shipping
Resolved
This incident has been resolved.
Posted Mar 10, 2020 - 15:25 EDT
Update
USPS is continuing to work on a fix to its international rating services.
Posted Mar 10, 2020 - 14:30 EDT
Update
We are continuing to monitor the situation.
Posted Mar 10, 2020 - 12:39 EDT
Update
We are continuing to monitor the situation and will post an update when USPS international rating has been restored by the carrier.
Posted Mar 10, 2020 - 10:55 EDT
Monitoring
USPS is currently experiencing issues with international rating. We are currently monitoring the situation.

If you are only using the USPS carrier service for international rating, we highly recommend setting up an additional carrier service until USPS is able to resolve this issue.
Posted Mar 10, 2020 - 10:38 EDT
Investigating
We are currently investigating an issue with USPS rates timing out.
Posted Mar 10, 2020 - 10:27 EDT
This incident affected: Intuitive Shipping (Rating).