Dashboard pagination
Incident Report for Intuitive Shipping
Resolved
A fix has been implemented and the issue is now resolved.
Posted Nov 13, 2019 - 12:37 EST
Identified
An issue with dashboard pagination has been identified. We are currently working on a fix.
Posted Nov 13, 2019 - 12:31 EST
This incident affected: Intuitive Shipping Legacy (Admin).