Canada Post Rating Impaired

Incident Report for Intuitive Shipping

Resolved

Canada Post has restored their service.
Posted Mar 09, 2026 - 13:18 EDT

Update

We are continuing to monitor for any further issues.
Posted Mar 09, 2026 - 13:07 EDT

Monitoring

Canada Post is currently experiencing rating issues. If you are solely using Canada Post rating, we recommend adding a fallback rate or fallback carrier to ensure your customers are able to complete their purchase.

https://knowledge.intuitiveshipping.com/create-a-parcel-service-shipping-method
Posted Mar 09, 2026 - 13:06 EDT
This incident affected: Intuitive Shipping (Rating).