High Latency
Incident Report for Intuitive Shipping
Postmortem

Intuitive Shipping experienced high latency which affected our file system for some stores, which unfortunately resulted in customers being unable to retrieve shipping rates at checkout.

The incident was the result of our rating API hitting the I/O limit of our file system which caused the operations to become throttled. We have migrated our file system to a higher throughput which removes this I/O limitation, and provisioned a higher throughput allowance to ensure latency remains minimal.

We apologize for any inconvenience this issue has caused. We take our uptime very serious and use incidents like these as learning experiences.

Sincerely,

Joel Reeds, Co-Founder / CTO

Posted Jul 10, 2019 - 16:57 EDT

Resolved
Intuitive Shipping is currently experiencing high latency which is causing some stores to see their shipping rates timeout.

We've identified the issue and have applied the necessary fix. We will continue to monitor the system.
Posted Jul 09, 2019 - 19:00 EDT