FedEx rating is down.
Incident Report for Intuitive Shipping Inc
Resolved
FedEx is now returning rates.
Posted Jul 21, 2021 - 16:00 EDT
Monitoring
FedEx is currently experiencing rating issues. If you are solely using FedEx rating, we recommend adding a fallback rate or fallback carrier to ensure your customers are able to complete their purchase. We are monitoring FedEx's progress in resolving the issue.
Posted Jul 21, 2021 - 14:21 EDT
This incident affected: Intuitive Shipping (Rating).