Canada Post has restored service and rates are now returning for merchants.
Posted Aug 07, 2026 - 16:02 EDT
Update
Canada Post is still experiencing intermittent issues with their rating service.
If you are solely using Canada Post rating, we recommend adding a fallback rate or fallback carrier to ensure your customers are able to complete their purchase.
Canada Post has restored service and rates are now returning for merchants.
Posted Aug 07, 2026 - 11:56 EDT
Identified
Canada Post has confirmed that they are currently performing maintenance, which is taking longer than expected. They do not have a firm ETA at this time but expect all affected services to be restored by 12:00 p.m. (noon) ET.
Posted Aug 07, 2026 - 09:14 EDT
Investigating
Canada Post is currently experiencing rating issues. If you are solely using Canada Post rating, we recommend adding a fallback rate or fallback carrier to ensure your customers are able to complete their purchase.