FedEx Timeout Issues
Incident Report for Intuitive Shipping
Resolved
This incident has been resolved.
Posted May 05, 2020 - 00:52 EDT
Identified
The FedEx carrier service is currently experiencing timeout issues.

If you are only using FedEx to provide rates, it is recommended to temporarily create backup rates until their service has been restored.
Posted May 05, 2020 - 00:48 EDT
This incident affected: Intuitive Shipping Legacy (Rating).