Issue Accessing Intuitive Shipping Admin

Incident Report for Intuitive Shipping

Resolved

This incident has been resolved.
Posted Oct 01, 2025 - 07:21 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 01, 2025 - 06:51 EDT

Investigating

We are currently experiencing intermittent issues accessing the Intuitive Shipping admin. We are investigating the cause of the issue and will update once we have more information. We apologize for any inconvenience.
Posted Oct 01, 2025 - 06:27 EDT
This incident affected: Intuitive Shipping (Admin).