ShipStation Rating Issues

Incident Report for Intuitive Shipping

Resolved

ShipStation has noted that the incident is resolved.
Posted Apr 21, 2026 - 14:36 EDT

Update

ShipStation has acknowledged the issue and are working toward a fix.

https://status.shipstation.com/incidents/jtgp6qvrqvx3
Posted Apr 20, 2026 - 22:30 EDT

Monitoring

ShipStation is currently experiencing higher than normal latency. This is causing some rating requests to timeout and resort to fallback rates.

We will update this incident once we have more information.
Posted Apr 20, 2026 - 19:40 EDT
This incident affected: Intuitive Shipping (Rating).