Mailing Error
Incident Report for Intuitive Shipping Inc
Postmortem

We’re very sorry about the incorrect emails that were sent out earlier.

The email was intended to be sent to installed users only. Shortly after sending the mail, it was identified that there was a bug in our uninstall script that caused some uninstalled stores to still be identified as installed within our system. Once this issue was determined, we immediately canceled the mail script.

It was also identified that we failed to include an unsubscribe link on the footer of the email. We have taken steps to remove anyone who has responded to the email requesting to be removed. We apologize for this oversight.

We’re working on migrating to a new mail platform to ensure this does not happen again in the future.

If you have any questions or concerns, please don’t hesitate to contact me directly at joel@intuitiveshipping.com

Kind regards,

Joel Reeds

Co-Founder / CTO

Posted Sep 14, 2020 - 20:21 EDT

Resolved
We've terminated the process and will provide an update shortly.
Posted Sep 14, 2020 - 18:33 EDT
Investigating
We are currently investigating a mailer issue which has resulted in a support update email being sent out multiple times to users. We apologize for the inconvenience this has caused and are working to determine the cause.
Posted Sep 14, 2020 - 18:31 EDT