DHL eCommerce Rating
Incident Report for Intuitive Shipping
Resolved
This incident has been resolved.
Posted May 08, 2020 - 16:42 EDT
Monitoring
A temporary fix has been put into place to get DHL eCommerce rates while their team works to resolve the issue with their rating service.
Posted May 08, 2020 - 16:03 EDT
Investigating
We are currently seeing timeout issues with the DHL eCommerce carrier service. We are investigating the issue and will provide an update shortly.

If you are using DHL eCommerce as your sole carrier service, we recommend temporarily adding a secondary carrier to ensure your customers are able to complete their purchase.
Posted May 08, 2020 - 15:31 EDT
This incident affected: Intuitive Shipping Legacy (Rating).