Help Center Experiencing Connection Issues
Incident Report for Intuitive Shipping
Resolved
This incident has been resolved.
Posted May 01, 2020 - 19:43 EDT
Identified
Our hosting provider for our website and Help Center is currently experiencing technical issues.

We will keep you updated when we expect service for these pages to be restored.
Posted May 01, 2020 - 18:58 EDT
Investigating
We are currently investigating connectivity issues with our Help Center and website.

These interruptions do not impact our apps or rating functionality.
Posted May 01, 2020 - 18:45 EDT