USPS International Rating Issues
Incident Report for Intuitive Shipping
Resolved
This incident has been resolved.
Posted Apr 28, 2020 - 15:44 EDT
Update
The USPS rating service appears to still be experiencing some issues. We've reached out to their technical support to provide an ETA on a solution.
Posted Apr 28, 2020 - 13:36 EDT
Monitoring
USPS rating services appear to be stable at the moment. We will continue to monitor for any outages.
Posted Apr 28, 2020 - 13:23 EDT
Investigating
We are currently investigating an intermittent issue with USPS rating returning a system error message from the carrier.

If you are using USPS as your primary rates provider, please add a secondary carrier to ensure your customers can continue to purchase products from your site.
Posted Apr 28, 2020 - 11:17 EDT
This incident affected: Intuitive Shipping Legacy (Rating).