Phone Support Interruption
Incident Report for Intuitive Shipping
Resolved
This incident has been resolved.
Posted Dec 09, 2019 - 11:40 EST
Investigating
Due to an issue with our service provider, we are unable to receive incoming phone calls at our support number (905-228-3555). We are currently working to resolve this.

If you require assistance in the meantime, please contact us through the form on our website: https://www.intuitiveshipping.com/contact/
Posted Dec 09, 2019 - 09:34 EST