ShipStation rating impaired
Incident Report for Intuitive Shipping
Resolved
Service has now been fully restored.
Posted Nov 20, 2024 - 15:15 EST
Monitoring
We are performing critical maintenance on our system that may affect ShipStation rates. If you are solely using ShipStation rating, we recommend adding a fallback rate or fallback carrier to ensure your customers can complete their purchase.

We expect for service to return to normal shortly.
Posted Nov 20, 2024 - 15:02 EST
This incident affected: Intuitive Shipping (Rating).