FedEx Carrier Service
Incident Report for Intuitive Shipping
Resolved
This incident has been resolved.
Posted May 30, 2020 - 16:58 EDT
Identified
FedEx rating services are currently experiencing high latency, causing them to timeout with no rate responses.

We recommend using an alternative carrier service in the meantime while FedEx works to restore their service.
Posted May 30, 2020 - 16:02 EDT
This incident affected: Intuitive Shipping (Rating).