USPS Service Interruptions
Incident Report for Intuitive Shipping
Resolved
This incident has been resolved.
Posted Jun 14, 2020 - 15:42 EDT
Update
USPS is continuing to experience intermittent issues. We're continuing to monitor their carrier service for restored service.
Posted Jun 14, 2020 - 13:07 EDT
Identified
USPS is currently experiencing an issue with their rating servers resulting in timeouts.

During this time, we recommend implementing a fallback shipping carrier or flat rates until they have resolved the issue.
Posted Jun 14, 2020 - 11:30 EDT
This incident affected: Intuitive Shipping Legacy (Rating).